summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2017-04-14 10:27:43 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-14 12:29:20 +0200
commitf252d6df8b630fc93c700d51a03be417ee734128 (patch)
tree4c9992a092e399d9aeff46bf0ed6b0eb7b131205
parent116b29bffbd09b26d03dff4997c87ffc8c77c2d8 (diff)
downloadpatches-f252d6df8b630fc93c700d51a03be417ee734128.tar
patches-f252d6df8b630fc93c700d51a03be417ee734128.tar.gz
gnu: Add guile-syntax-highlight.
* gnu/packages/guile.scm (guile-syntax-highlight): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d2e832aae5..ff7cf40811 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Amirouche <amirouche@hypermove.net>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
+;;; Copyright © 2017 David Thompson <davet@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1732,4 +1733,39 @@ is not available for Guile 2.0.")
manipulate repositories of the Git version control system.")
(license license:gpl3+))))
+(define-public guile-syntax-highlight
+ (let ((commit "a047675e66861b647426372aa2ba7820f749616d")
+ (revision "0"))
+ (package
+ (name "guile-syntax-highlight")
+ (version (string-append "0.0." revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://dthompson.us/guile-syntax-highlight.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1zjr6sg3n7xbdsliy45i39dqanxvcms58ayx36wxrz72zpq58vq3"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (zero? (system* "sh" "bootstrap")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (synopsis "General-purpose syntax highlighter for GNU Guile")
+ (description "Guile-syntax-highlight is a general-purpose syntax
+highlighting library for GNU Guile. It can parse code written in various
+programming languages into a simple s-expression that can be converted to
+HTML (via SXML) or any other format for rendering.")
+ (home-page "http://dthompson.us/software/guile-syntax-highlight")
+ (license license:lgpl3+))))
+
;;; guile.scm ends here