summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-19 23:28:19 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:16:55 +0100
commitd6fa189eefabdfdd4cca955b98b7b90f0cc07c75 (patch)
tree3721960b7b80a79efeb0ad15a88d5a53e32a2d7f
parent48b27902ded3aa89e18b8e46bb0a48f91ea4ae23 (diff)
downloadpatches-d6fa189eefabdfdd4cca955b98b7b90f0cc07c75.tar
patches-d6fa189eefabdfdd4cca955b98b7b90f0cc07c75.tar.gz
gnu: ocaml-re: Use dune-build-system.
* gnu/packages/ocaml.scm (ocaml-re): Use dune-build-system.
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index fe5c6b55c8..a776266dff 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3663,26 +3663,14 @@ standard iterator type starting from 4.07.")
(sha256
(base32
"1pdb0mr6z5ax6szblr3f5lbdnqq9grm97cmsfjmdma60yrx2rqhd"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
`(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "dune" "build" "@install" "--profile" "release")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "dune" "install"
- "--prefix" (assoc-ref outputs "out"))
- #t)))))
+ #:build-flags (list "--profile" "release")))
(propagated-inputs
`(("ocaml-seq" ,ocaml-seq)))
(native-inputs
- `(("dune" ,dune)
- ("ounit" ,ocaml-ounit)))
+ `(("ounit" ,ocaml-ounit)))
(home-page "https://github.com/ocaml/ocaml-re/")
(synopsis "Regular expression library for OCaml")
(description "Pure OCaml regular expressions with: