summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-07-24 19:44:24 -0400
committerAlex Kost <alezost@gmail.com>2017-07-29 23:19:17 +0300
commitd0a5205292a24f350522bf461582cac5242f0cfa (patch)
tree9407ca12b327138c38f3e84111d54c58bda4aa54
parent469c7ce058a6477bfdc1d965b17c3fb296df424b (diff)
downloadpatches-d0a5205292a24f350522bf461582cac5242f0cfa.tar
patches-d0a5205292a24f350522bf461582cac5242f0cfa.tar.gz
gnu: Remove emacs-seq.
The seq.el library has been included with Emacs since version 25.1. * gnu/packages/emacs.scm (emacs-seq): Remove variable. (flycheck, emacs-cider)[propagated-inputs]: Remove emacs-seq. Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 2 insertions, 24 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index aae153b1c6..02e7a9e908 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -655,8 +655,7 @@ programs.")
"1rxzkaqsj48z3nska5wsgwafvwkam014dzqd32baycmxjl0jxvy7"))))
(build-system emacs-build-system)
(propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-seq" ,emacs-seq)))
+ `(("emacs-dash" ,emacs-dash)))
(home-page "https://www.flycheck.org")
(synopsis "On-the-fly syntax checking")
(description
@@ -3007,26 +3006,6 @@ be removed from the front. This type of data structure is sometimes called an
ongoing operations.")
(license license:gpl3+)))
-(define-public emacs-seq
- (package
- (name "emacs-seq")
- (version "2.19")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/seq-"
- version ".tar"))
- (sha256
- (base32
- "11hb7is6a4h1lscjcfrzh576j0g3m5yjydn16s6x5bxp5gsr6zha"))))
- (build-system emacs-build-system)
- (home-page "https://elpa.gnu.org/packages/seq.html")
- (synopsis "Sequence manipulation functions for Emacs")
- (description
- "This Emacs library provides sequence-manipulation functions that
-complement basic functions provided by @code{subr.el}. All provided functions
-work on lists, strings and vectors.")
- (license license:gpl3+)))
-
(define-public emacs-sparql-mode
(package
(name "emacs-sparql-mode")
@@ -3532,8 +3511,7 @@ for search-based navigation of buffers.")
`(("emacs-clojure-mode" ,emacs-clojure-mode)
("emacs-spinner" ,emacs-spinner)
("emacs-pkg-info" ,emacs-pkg-info)
- ("emacs-queue" ,emacs-queue)
- ("emacs-seq" ,emacs-seq)))
+ ("emacs-queue" ,emacs-queue)))
(home-page "https://cider.readthedocs.org/")
(synopsis "Clojure development environment for Emacs")
(description