summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-05-06 00:41:44 -0400
committerArun Isaac <arunisaac@systemreboot.net>2017-05-06 16:16:11 +0530
commita34242eedc4073435f399a5336f227f175e9577f (patch)
tree5d01248213d1209759841db66b5bc0851ce980b5
parentc0326ebcb5825fbb5ffc59df40db36aef0a7d47a (diff)
downloadpatches-a34242eedc4073435f399a5336f227f175e9577f.tar
patches-a34242eedc4073435f399a5336f227f175e9577f.tar.gz
gnu: Add emacs-key-chord.
* gnu/packages/emacs.scm (emacs-key-chord): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fac04e2c9c..7e39c2a234 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4580,3 +4580,22 @@ with gnuplot.")
functions which allows users to transpose windows arrangement in currently
selected frame.")
(license license:bsd-2)))
+
+(define-public emacs-key-chord
+ (package
+ (name "emacs-key-chord")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.emacswiki.org/emacs/download/key-chord.el")
+ (sha256
+ (base32
+ "03m44pqggfrd53nh9dvpdjgm0rvca34qxmd30hr33hzprzjambxg"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/key-chord.el")
+ (synopsis "Map pairs of simultaneously pressed keys to Emacs commands")
+ (description "@code{emacs-key-chord} provides @code{key-chord-mode}, a
+mode for binding key chords to commands. A key chord is defined as two keys
+pressed simultaneously or a single key quickly pressed twice.")
+ (license license:gpl2+)))