summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Clemmer <myglc2@gmail.com>2017-04-10 18:31:52 -0400
committerAlex Kost <alezost@gmail.com>2017-04-12 21:09:49 +0300
commit99517d92709ee979c3507994caeb18db1eed08a6 (patch)
treeb5639faf4b9f3d63972905c11c1f89405ca76718
parent352074d5a96aa47cc7977d38b948b9d219006792 (diff)
downloadpatches-99517d92709ee979c3507994caeb18db1eed08a6.tar
patches-99517d92709ee979c3507994caeb18db1eed08a6.tar.gz
gnu: emacs-ag: Build and install info.
* gnu/packages/emacs.scm (emacs-ag)[arguments]: Add 'make-info' and 'install-info' phases. Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/emacs.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d8f3c228ba..65a491302c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2017 George Clemmer <myglc2@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,6 +59,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages python)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tcl)
@@ -1128,9 +1130,22 @@ than @code{electric-indent-mode}.")
("ag-executable"
(string-append (assoc-ref inputs "the-silver-searcher")
"/bin/ag")))
- #t)))))
+ #t))
+ (add-before 'install 'make-info
+ (lambda _
+ (with-directory-excursion "docs"
+ (zero? (system* "make" "info")))))
+ (add-after 'install 'install-info
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (info (string-append out "/share/info")))
+ (install-file "docs/_build/texinfo/agel.info" info)
+ #t))))))
(inputs
`(("the-silver-searcher" ,the-silver-searcher)))
+ (native-inputs
+ `(("python-sphinx" ,python-sphinx)
+ ("texinfo" ,texinfo)))
(propagated-inputs
`(("dash" ,emacs-dash)
("s" ,emacs-s)))