summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 20:51:02 +0200
committerGuix Patches Tester <>2020-05-24 21:36:12 +0100
commit770c27d9f5f5d16b098cfd1e1714c007d238e73c (patch)
treed7d3ed83a2ef4f6306c81c96bb421f291b1ef722
parent101baed6f41f3896086fd3cdeb24cee895477039 (diff)
downloadpatches-770c27d9f5f5d16b098cfd1e1714c007d238e73c.tar
patches-770c27d9f5f5d16b098cfd1e1714c007d238e73c.tar.gz
gnu: Add libpepadapter.
* gnu/packages/pep.scm (libpepadapter): New variable.
-rw-r--r--gnu/packages/pep.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 57fb0e88f3..9452435c35 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -153,3 +153,44 @@ messages")
privacy).")
(license ;; code: GPL 3, docs: CC-BY-SA
(list license:gpl3 license:cc-by-sa3.0))))
+
+(define-public libpepadapter
+ (package
+ (name "libpepadapter")
+ (version "2.0.2")
+ (source
+ (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://pep.foundation/dev/repos/libpEpAdapter")
+ (changeset "e8fe371c870a"))) ;; r168
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "1mlpavjbnmslvmr5jxcvpjgb2x40nhmxjb10hza3kn4qzj0k1pjz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:test-target "test"
+ #:tests? #f ;; building the tests fails
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; libpEpAdapter does not use autotools and configure,
+ ;; but a local.conf. We need to tweak the values there.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (engine (assoc-ref inputs "pep-engine")))
+ (with-output-to-file "local.conf"
+ (lambda _ ;()
+ (format #t "
+PREFIX=~a
+ENGINE_LIB_PATH=~a/lib
+ENGINE_INC_PATH=~a/include
+" out engine engine))))
+ #t)))))
+ (inputs
+ `(("pep-engine" ,pep-engine)))
+ (home-page "https://pep.foundation/")
+ (synopsis "Library for building p≡p adapters")
+ (description "This C++ library provides common structures used in p≡p
+(pretty Easy privacy) adapters.")
+ (license license:bsd-3)))