summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-04-14 13:44:02 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-04-14 18:16:15 +0530
commit4e644ab8a6b67d1e9db459c31d8f23ee14276140 (patch)
tree6a7e02b5afb57738f88aa1b9535c7b9bc358cd87
parent960887b2974ff5c3e63f58a1d89cd8d0dcb5e045 (diff)
downloadpatches-4e644ab8a6b67d1e9db459c31d8f23ee14276140.tar
patches-4e644ab8a6b67d1e9db459c31d8f23ee14276140.tar.gz
gnu: emacs-company: Enable tests.
* gnu/packages/emacs.scm (emacs-company)[arguments]: Add a 'check' phase.
-rw-r--r--gnu/packages/emacs.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 71058136a6..976ea31e00 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2088,6 +2088,18 @@ build jobs.")
(base32
"1fyrpchpdmvszssy1qmsw41aqpv6q5rybvs1bw00nv9xdhiaq4vh"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda _
+ ;; The company-files-candidates-normal-root test looks
+ ;; for the /bin directory, but the build environment has
+ ;; no /bin directory. Modify the test to look for the
+ ;; /tmp directory.
+ (substitute* "test/files-tests.el"
+ (("/bin/") "/tmp/"))
+ (zero? (system* "make" "test-batch")))))))
(home-page "http://company-mode.github.io/")
(synopsis "Modular text completion framework")
(description