summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-06 15:52:22 -0400
committerLeo Famulari <leo@famulari.name>2017-05-06 15:53:58 -0400
commit2f0ad2a4232549a3bbb43565fa3b82a6c85e59a8 (patch)
tree375bc31e8606b9526ac03e2daf0e9a38fc2eab1e
parent17139eff16abb9f607bf8fdbf36b1410a314c41d (diff)
downloadpatches-2f0ad2a4232549a3bbb43565fa3b82a6c85e59a8.tar
patches-2f0ad2a4232549a3bbb43565fa3b82a6c85e59a8.tar.gz
Revert "gnu: hexchat: Update to 2.12.4."
This reverts commit 09270a97d9297e8acf6d9ff224dd1d58e2a4498e. The source derivation failed to build with: /gnu/store/19lkrck1844idbcfq6ajzr0akmr8rshj-hexchat-2.12.4.tar.xz-builder:1:2293: In procedure #<procedure f6fdc0 ()>: /gnu/store/19lkrck1844idbcfq6ajzr0akmr8rshj-hexchat-2.12.4.tar.xz-builder:1:2293: In procedure module-lookup: Unbound variable: inputs
-rw-r--r--gnu/packages/messaging.scm35
1 files changed, 5 insertions, 30 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 6bd626d78c..9e45b7ad0f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2017 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -166,35 +166,17 @@ identi.ca and status.net).")
(define-public hexchat
(package
(name "hexchat")
- (version "2.12.4")
+ (version "2.12.2")
(source (origin
(method url-fetch)
(uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
version ".tar.xz"))
(sha256
(base32
- "0ficrx56knz5y297qb0x5y02339yvyv734z7kpcx1ixvb0qr2dgs"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete dangling symlinks to a non-existent ‘/usr’.
- (with-directory-excursion "m4"
- (for-each (lambda (f) (delete-file f))
- '("intltool.m4" "libtool.m4" "lt~obsolete.m4"
- "ltoptions.m4" "ltsugar.m4" "ltversion.m4")))
- (delete-file-recursively "build-aux")
- (delete-file "po/Makefile.in.in")
- ;; This file is still required for autoreconf.
- (copy-file (string-append (assoc-ref inputs "intltool")
- "/share/intltool/Makefile.in.in")
- "po/Makefile.in.in")))))
+ "1xnclfbrgbkqndxygi5f27q00jd7yy54jbd1061jmhxa6wzpibbd"))))
(build-system gnu-build-system)
- (native-inputs `(("autoconf" ,autoconf)
- ("autoconf-archive" ,autoconf-archive)
- ("automake" ,automake)
- ("intltool" ,intltool)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
(inputs `(("dbus-glib" ,dbus-glib)
("dbus" ,dbus)
("enchant" ,enchant)
@@ -208,13 +190,6 @@ identi.ca and status.net).")
("luajit" ,luajit)
("perl-xml-parser" ,perl-xml-parser)
("python-2" ,python-2)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Release 2.12.4 wasn't properly bootstrapped. Later ones might be!
- (add-after 'unpack 'bootstrap
- (lambda* (#:key inputs #:allow-other-keys)
- (zero? (system* "autoreconf" "-fiv")))))))
(synopsis "Graphical IRC Client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main