summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-17 19:48:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-17 20:02:18 +0100
commit820373dbc82dfccf0edd779a4ab4b68672432a2d (patch)
tree1075c316e96d7e236cd2ad7e9ea1e2f9e365286e
parent6ca6f8663b1d7b5d0e6c8f33bd9420d1ade832db (diff)
downloadpatches-820373dbc82dfccf0edd779a4ab4b68672432a2d.tar
patches-820373dbc82dfccf0edd779a4ab4b68672432a2d.tar.gz
gnu: Add r-bigmemoryextras.
* gnu/packages/bioconductor.scm (r-bigmemoryextras): New variable.
-rw-r--r--gnu/packages/bioconductor.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f388f16e23..0e817a1fb6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6783,3 +6783,35 @@ reconstruction databases. The package facilitates @dfn{flux balance
analysis} (FBA) and the sampling of feasible flux distributions. Metabolic
networks and estimated fluxes can be visualized with hypergraphs.")
(license license:gpl3+)))
+
+(define-public r-bigmemoryextras
+ (package
+ (name "r-bigmemoryextras")
+ (version "1.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "bigmemoryExtras" version))
+ (sha256
+ (base32
+ "17dk7c44ikphcrpi8hnxyvlmj30qmj098kc0ihfi69bp9rw1cibq"))))
+ (properties
+ `((upstream-name . "bigmemoryExtras")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bigmemory" ,r-bigmemory)))
+ (home-page "https://github.com/phaverty/bigmemoryExtras")
+ (synopsis "Extension of the bigmemory package")
+ (description
+ "This package defines a @code{BigMatrix} @code{ReferenceClass} which adds
+safety and convenience features to the @code{filebacked.big.matrix} class from
+the @code{bigmemory} package. @code{BigMatrix} protects against segfaults by
+monitoring and gracefully restoring the connection to on-disk data and it also
+protects against accidental data modification with a filesystem-based
+permissions system. Utilities are provided for using @code{BigMatrix}-derived
+classes as @code{assayData} matrices within the @code{Biobase} package's
+@code{eSet} family of classes. @code{BigMatrix} provides some optimizations
+related to attaching to, and indexing into, file-backed matrices with
+dimnames. Additionally, the package provides a @code{BigMatrixFactor} class,
+a file-backed matrix with factor properties.")
+ (license license:artistic2.0)))