summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-17 19:18:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-17 20:02:16 +0100
commit1028bf0a05ee2f44d41f56eecd5ae6f72f150e05 (patch)
tree97916f64acef0e3374e13f9bbd8cbfd09e053e66
parent59d485e118fab91c36937704396d1045f2e0815a (diff)
downloadpatches-1028bf0a05ee2f44d41f56eecd5ae6f72f150e05.tar
patches-1028bf0a05ee2f44d41f56eecd5ae6f72f150e05.tar.gz
gnu: Add r-rsvg.
* gnu/packages/cran.scm (r-rsvg): New variable.
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c5e6b96f67..1f15e29b06 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18910,3 +18910,31 @@ the css-loaders created by Luke Hass
@url{https://github.com/lukehaas/css-loaders}. Wrapping a Shiny output will
automatically show a loader when the output is (re)calculating.")
(license license:gpl3)))
+
+(define-public r-rsvg
+ (package
+ (name "r-rsvg")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rsvg" version))
+ (sha256
+ (base32
+ "11mccgf6hfskg45wqc114sx3qy2r494y6axdf73z6xwhs1wpm97g"))))
+ (properties `((upstream-name . "rsvg")))
+ (build-system r-build-system)
+ (inputs
+ `(("librsvg" ,librsvg)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/jeroen/rsvg#readme")
+ (synopsis "Render SVG images into PDF, PNG, PostScript, or Bitmap arrays")
+ (description
+ "This package allows you to render vector-based SVG images into
+high-quality custom-size bitmap arrays using the librsvg2 library. The
+resulting bitmap can be written to e.g. PNG, JPEG or WEBP format. In
+addition, the package can convert images directly to various formats such as
+PDF or PostScript.")
+ (license license:expat)))