summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-09-22 14:08:05 +0100
committerBen Woodcroft <donttrustben@gmail.com>2016-09-27 20:06:00 +1000
commitdff26b2363c1735e3d84e0dbd2b958760b08f848 (patch)
treeb270fc8951ef2797ba2288ac4c817b745aeb5eb5
parent397d463a12b719146ffe4f444f5f3e83cee4794e (diff)
downloadpatches-dff26b2363c1735e3d84e0dbd2b958760b08f848.tar
patches-dff26b2363c1735e3d84e0dbd2b958760b08f848.tar.gz
gnu: python-pysam: Delete bundled htslib.
* gnu/packages/bioinformatics.scm (python-pysam)[source]: Add snippet to delete htslib. [arguments]: Add htslib flags in 'set-flags phase. [propagated-inputs]: New field. Add htslib.
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a6e3218a26..3ca6fd6c34 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1354,17 +1354,28 @@ multiple sequence alignments.")
(uri (pypi-uri "pysam" version))
(sha256
(base32
- "1i1djacqbr88y7w18b4aa78zxnsyr4sz7yqdq2spi7gs0y6pzvjn"))))
+ "1i1djacqbr88y7w18b4aa78zxnsyr4sz7yqdq2spi7gs0y6pzvjn"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Drop bundled htslib. TODO: Also remove samtools and bcftools.
+ '(delete-file-recursively "htslib"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; tests are excluded in the manifest
#:phases
(modify-phases %standard-phases
(add-before 'build 'set-flags
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "HTSLIB_MODE" "external")
+ (setenv "HTSLIB_LIBRARY_DIR"
+ (string-append (assoc-ref inputs "htslib") "/lib"))
+ (setenv "HTSLIB_INCLUDE_DIR"
+ (string-append (assoc-ref inputs "htslib") "/include"))
(setenv "LDFLAGS" "-lncurses")
(setenv "CFLAGS" "-D_CURSES_LIB=1")
#t)))))
+ (propagated-inputs
+ `(("htslib" ,htslib))) ; Included from installed header files.
(inputs
`(("ncurses" ,ncurses)
("zlib" ,zlib)))