summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-05 14:03:31 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:37 -0500
commitbdc877c4d273bbb6ee0d21cdceb3ff36804a076c (patch)
tree32f5dc587c74df80ea4ec68b3ede344fff87a413
parent13e889a7583a38669f6c5feacea872945a3a1522 (diff)
downloadpatches-bdc877c4d273bbb6ee0d21cdceb3ff36804a076c.tar
patches-bdc877c4d273bbb6ee0d21cdceb3ff36804a076c.tar.gz
gnu: Add ghc-text-metrics.
* gnu/packages/haskell-xyz.scm (ghc-text-metrics): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5ad900a627..46bf1e53c8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10435,6 +10435,33 @@ instances for strict and lazy text types for versions older than 1.2.1 of the
text package.")
(license license:bsd-2)))
+(define-public ghc-text-metrics
+ (package
+ (name "ghc-text-metrics")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "text-metrics/text-metrics-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18mzxwkdvjp31r720ai9bnxr638qq8x3a2v408bz0d8f0rsayx1q"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)))
+ (arguments
+ `(#:cabal-revision
+ ("4" "017drxq9x56b345d8w5m8xdsi1zzs0z16pbdx8j35cd1lsnh3kf1")))
+ (home-page "https://github.com/mrkkrp/text-metrics")
+ (synopsis "Calculate various string metrics efficiently")
+ (description "This library provides tools to calculate various
+string metrics efficiently.")
+ (license license:bsd-3)))
+
(define-public ghc-tf-random
(package
(name "ghc-tf-random")