summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:21:58 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:37 -0500
commitb58e5b84235382954838e3a3af3e4a4f2dc41d6d (patch)
tree458a5278017704426ad3367bf6a29a955c63f5ef
parent0c2d6fc22af6cde42909709458361d0dcecd2c99 (diff)
downloadpatches-b58e5b84235382954838e3a3af3e4a4f2dc41d6d.tar
patches-b58e5b84235382954838e3a3af3e4a4f2dc41d6d.tar.gz
gnu: ghc-yaml: Update to 0.11.1.2.
* gnu/packages/haskell-xyz.scm (ghc-yaml): Update to 0.11.1.2. [arguments]: Enable tests. [inputs]: Add 'ghc-libyaml'. [native-inputs]: Add 'ghc-raw-strings-qq'.
-rw-r--r--gnu/packages/haskell-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 755a627ee7..b8bd712442 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -12013,18 +12013,15 @@ documents.")
(define-public ghc-yaml
(package
(name "ghc-yaml")
- (version "0.8.32")
+ (version "0.11.1.2")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"yaml/yaml-" version ".tar.gz"))
(sha256
(base32
- "0cbsyh4ilvjzq1q7pxls43k6pdqxg1l85xzibcwpbvmlvrizh86w"))))
+ "028pz77n92l6kjgjv263h4b6yhw1iibdbf3a3dkn5qnz537xpzhc"))))
(build-system haskell-build-system)
- ;; The tests are broken on i686. They are fixed in 0.10.3.0.
- ;; See https://github.com/snoyberg/yaml/issues/158
- (arguments `(#:tests? #f))
(inputs
`(("ghc-conduit" ,ghc-conduit)
("ghc-resourcet" ,ghc-resourcet)
@@ -12036,12 +12033,14 @@ documents.")
("ghc-semigroups" ,ghc-semigroups)
("ghc-temporary" ,ghc-temporary)
("ghc-enclosed-exceptions" ,ghc-enclosed-exceptions)
- ("ghc-base-compat" ,ghc-base-compat)))
+ ("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-libyaml" ,ghc-libyaml)))
(native-inputs
`(("ghc-hspec" ,ghc-hspec)
("ghc-hunit" ,ghc-hunit)
("hspec-discover" ,hspec-discover)
- ("ghc-mockery" ,ghc-mockery)))
+ ("ghc-mockery" ,ghc-mockery)
+ ("ghc-raw-strings-qq" ,ghc-raw-strings-qq)))
(home-page "https://github.com/snoyberg/yaml/")
(synopsis "Parsing and rendering YAML documents")
(description