summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-08-26 23:56:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-09-12 22:16:23 -0400
commit7e846d07e83e5d63eee42c9361a2d1a933f79883 (patch)
tree7f90a411a051e9dc399c736be351deaac32b8843
parent4bd8f4f3028fcabf90c5c262ac237c037e668939 (diff)
downloadpatches-7e846d07e83e5d63eee42c9361a2d1a933f79883.tar
patches-7e846d07e83e5d63eee42c9361a2d1a933f79883.tar.gz
gnu: Add python-toml.
* gnu/packages/python.scm (python-toml): New variables.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 88c971b328..793961d944 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2721,6 +2722,27 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(define-public python2-feedgenerator
(package-with-python2 python-feedgenerator))
+(define-public python-toml
+ (package
+ (name "python-toml")
+ (version "0.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "toml" version))
+ (sha256
+ (base32
+ "0bdbpbip67wdm6c7xwc6mmbmskyradj4cdxn1iibj4fcx1nbv1lf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests suite in release
+ (home-page "https://github.com/uiri/toml")
+ (synopsis "Library for TOML")
+ (description
+ "@code{toml} is a library for parsing and creating Tom's Obvious, Minimal
+Language (TOML) configuration files.")
+ (license license:expat)))
+
(define-public python-blinker
(package
(name "python-blinker")