summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-18 19:26:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-08-08 15:18:31 +0300
commit70782dddffc2da05fed6aba35c3121a2265fd649 (patch)
tree6562c0b0140a4447175508889f9080fcdad970d6
parent8cd51276e53fc4988029bcd2de2b69db68ea6e05 (diff)
downloadpatches-70782dddffc2da05fed6aba35c3121a2265fd649.tar
patches-70782dddffc2da05fed6aba35c3121a2265fd649.tar.gz
gnu: Add fsom.
* gnu/packages/bioinformatics.scm (fsom): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 086e9324cb..a3c83f73bb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14932,3 +14932,33 @@ combination generation algorithm which is (approximately) described in
combinatorial configurations.\", G. Ehrlich - Journal of the ACM (JACM),
1973. (Algorithm 7.)")
(license license:expat)))
+
+(define-public fsom
+ (let ((commit "a6ef318fbd347c53189384aef7f670c0e6ce89a3"))
+ (package
+ (name "fsom")
+ (version (git-version "0.0.0" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekg/fsom/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gw1lpvr812pywg9y546x0h1hhj261xwls41r6kqhddjlrcjc0pi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests to run.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "fsom" bin))
+ #t)))))
+ (home-page "https://github.com/ekg/fsom")
+ (synopsis "Manage SOM (Self-Organizing Maps) neural networks")
+ (description "A tiny C library for managing SOM (Self-Organizing Maps)
+neural networks.")
+ (license license:gpl3))))