summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:17:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 05:11:31 +0200
commit67f1db3864ff26048d852adbc2bac4a67fce3879 (patch)
treedaed600886f0dafdcaeb0ad3b8ea75d8a0d81cc4
parentf541d86de675a33b58488526bdc08b06bd905d8a (diff)
downloadpatches-67f1db3864ff26048d852adbc2bac4a67fce3879.tar
patches-67f1db3864ff26048d852adbc2bac4a67fce3879.tar.gz
gnu: muparser: Don't use unstable tarball.
* gnu/packages/maths.scm (muparser)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ccb7a56099..a71e783e49 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2950,13 +2950,13 @@ associated functions (eg. contiguous and non-contiguous submatrix views).")
(version (string-append upstream-version "-" revision))
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/beltoforion/muparser/archive/v"
- upstream-version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beltoforion/muparser.git")
+ (commit (string-append "v" upstream-version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0277qsi5l23jsck1vhn383bmvc2n9l4a1dl5r9bf7hvjv9ayyrh6"))))
+ (base32 "0f0g4995xngf1pp3zr4p6ai2f8v6f8bxwa0k8ayjjiv1l8h44m24"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-samples=no")