summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-02-12 22:09:12 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-09-12 22:16:24 -0400
commit2c6ff3a2bc9846e6233013049bde28fafca3ee2b (patch)
treefcd0479d3a34e5a66711fc0236c3398019359081
parent563f151bd42c51b56794bee307148beef7fada26 (diff)
downloadpatches-2c6ff3a2bc9846e6233013049bde28fafca3ee2b.tar
patches-2c6ff3a2bc9846e6233013049bde28fafca3ee2b.tar.gz
gnu: Add emacs-find-file-in-project.
* gnu/packages/emacs.scm (emacs-find-file-in-project): New variable.
-rw-r--r--gnu/packages/emacs.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 741351f7f6..d8e83136d5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4528,6 +4528,39 @@ It uses regular Lisp rather than a domain specific language (DSL), which
maximizes flexibility (at the expense of conciseness).")
(license license:gpl2+)))
+(define-public emacs-find-file-in-project
+ (package
+ (name "emacs-find-file-in-project")
+ (version "5.4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/technomancy/find-file-in-project.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1sdnyqv69mipbgs9yax88m9b6crsa59rjhwrih197pifl4089awr"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-shell
+ ;; Otherwise Emacs shell-file-name is set to "/bin/sh", which doesn't
+ ;; work.
+ (lambda _
+ (setenv "SHELL" (which "sh"))
+ #t)))
+ #:tests? #t
+ #:test-command '("./tests/test.sh")))
+ (home-page "https://github.com/technomancy/find-file-in-project")
+ (synopsis "File/directory finder for Emacs")
+ (description "@code{find-file-in-project} allows to find files or
+directories quickly in the current project. The project root is detected
+automatically when Git, Subversion or Mercurial are used. It also provides
+functions to assist in reviewing changes on files.")
+ (license license:gpl3+)))
+
(define-public emacs-rainbow-delimiters
(package
(name "emacs-rainbow-delimiters")