summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMohammed Sadiq <sadiq@sadiqpk.org>2017-09-22 21:29:34 +0530
committerLudovic Courtès <ludo@gnu.org>2017-09-23 18:35:24 +0200
commit0ec171ecb4d3ee253210dca1dc778383cd0fc400 (patch)
treef8671136d37e4fe992ad90b1ec6b0ef4ae174e1e
parent1d3fcf944a0a7eb187f8edf2ba59d6e9497d2d98 (diff)
downloadpatches-0ec171ecb4d3ee253210dca1dc778383cd0fc400.tar
patches-0ec171ecb4d3ee253210dca1dc778383cd0fc400.tar.gz
gnu: Add gsound.
* gnu/packages/gnome.scm (gsound): New public variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ebfc844aab..c0b5a8a41a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5967,6 +5967,34 @@ specified duration and save it as a GIF encoded animated image file.")
(home-page "https://git.gnome.org/browse/byzanz")
(license license:gpl2+))))
+(define-public gsound
+ (package
+ (name "gsound")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0lwfwx2c99qrp08pfaj59pks5dphsnxjgrxyadz065d8xqqgza5v"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gobject-introspection" ,gobject-introspection)
+ ("vala" ,vala)))
+ (inputs
+ `(("glib" ,glib)
+ ("libcanberra" ,libcanberra)))
+ (home-page "https://wiki.gnome.org/Projects/GSound")
+ (synopsis "GObject wrapper for libcanberra")
+ (description
+ "GSound is a small library for playing system sounds. It's designed to be
+used via GObject Introspection, and is a thin wrapper around the libcanberra C
+library.")
+ (license license:lgpl2.1+)))
+
(define-public libzapojit
(package
(name "libzapojit")