summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-05-22 18:16:13 +0200
committerGuix Patches Tester <>2020-05-24 21:35:46 +0100
commita0a0d4325993c52e6a38a2c27e81864578b3ecd4 (patch)
tree2a2976b71a19bd0efe6aad95af1e1c36e8f486c0
parent2ae11cd0a43bfd8c0106afc620c2e5be1cecef78 (diff)
downloadpatches-a0a0d4325993c52e6a38a2c27e81864578b3ecd4.tar
patches-a0a0d4325993c52e6a38a2c27e81864578b3ecd4.tar.gz
gnu: Add go-github-com-stretchr-objx.
* gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ae59ad2b7..6da42884d6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -917,6 +917,28 @@ increment versions.")
Go.")
(license license:expat))))
+(define-public go-github-com-stretchr-objx
+ (package
+ (name "go-github-com-stretchr-objx")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stretchr/objx.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pcdvakxgddaiwcdj73ra4da05a3q4cgwbpm2w75ycq4kzv8ij8k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/stretchr/objx"))
+ (home-page "https://github.com/stretchr/objx")
+ (synopsis "Go package for dealing with maps, slices, JSON and other data")
+ (description "Go package for dealing with maps, slices, JSON and other data")
+ (license license:expat)))
+
(define-public go-github-com-stretchr-testify
(let ((commit
"b1f989447a57594c728884458a39abf3a73447f7")