summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-05-22 18:16:14 +0200
committerGuix Patches Tester <>2020-05-24 21:35:46 +0100
commit2196863893cb078f8359b5af51628bbf91bb5bd3 (patch)
tree95a114a2dc547889bfd10abb467ce0fdd32a3457
parenta0a0d4325993c52e6a38a2c27e81864578b3ecd4 (diff)
downloadpatches-2196863893cb078f8359b5af51628bbf91bb5bd3.tar
patches-2196863893cb078f8359b5af51628bbf91bb5bd3.tar.gz
gnu: go-github-com-davecgh-go-spew: Update to 1.1.1.
* gnu/packages/golang.scm (go-github-com-davecgh-go-spew): Update to 1.1.1.
-rw-r--r--gnu/packages/golang.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6da42884d6..726b74486a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1930,28 +1930,26 @@ that's a lot faster (and only does simple bandwidth metrics).")
(license license:expat))))
(define-public go-github-com-davecgh-go-spew
- (let ((commit "d8f796af33cc11cb798c1aaeb27a4ebc5099927d")
- (revision "0"))
- (package
- (name "go-github-com-davecgh-go-spew")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/davecgh/go-spew.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19z27f306fpsrjdvkzd61w1bdazcdbczjyjck177g33iklinhpvx"))))
- (build-system go-build-system)
- (arguments
- '(#:unpack-path "github.com/davecgh/go-spew"
- #:import-path "github.com/davecgh/go-spew/spew"))
- (home-page "https://github.com/davecgh/go-spew")
- (synopsis "Deep pretty printer for Go data structures to aid in debugging")
- (description "Package @command{spew} implements a deep pretty printer
+ (package
+ (name "go-github-com-davecgh-go-spew")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davecgh/go-spew.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hka6hmyvp701adzag2g26cxdj47g21x6jz4sc6jjz1mn59d474y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/davecgh/go-spew"
+ #:import-path "github.com/davecgh/go-spew/spew"))
+ (home-page "https://github.com/davecgh/go-spew")
+ (synopsis "Deep pretty printer for Go data structures to aid in debugging")
+ (description "Package @command{spew} implements a deep pretty printer
for Go data structures to aid in debugging.
A quick overview of the additional features spew provides over the built-in printing facilities for Go data types are as follows:
@@ -1967,7 +1965,7 @@ pointer receiver are optionally invoked when passing non-pointer variables.
includes offsets, byte values in hex, and ASCII output (only when using Dump
style).
@end itemize\n")
- (license license:isc))))
+ (license license:isc)))
(define-public go-github-com-btcsuite-btclog
(let ((commit "84c8d2346e9fc8c7b947e243b9c24e6df9fd206a")