summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior via Guix-patches via <guix-patches@gnu.org>2020-05-21 00:57:36 +0000
committerGuix Patches Tester <>2020-05-24 21:34:54 +0100
commit5c7436ef81979be12e5c7ba86fc423b89fb90e28 (patch)
tree255f62d9eb480d8a1bd92cdac6e0eff19637c6bb
parentc155d4ea62e5e209e8176e719997d8fd909d2937 (diff)
downloadpatches-5c7436ef81979be12e5c7ba86fc423b89fb90e28.tar
patches-5c7436ef81979be12e5c7ba86fc423b89fb90e28.tar.gz
gnu: Add sdcc-wrapper.
* gnu/packages/sdcc.scm (sdcc-wrapper): New variable.
-rw-r--r--gnu/packages/sdcc.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/sdcc.scm b/gnu/packages/sdcc.scm
index 6d05470101..a95ef2ac0f 100644
--- a/gnu/packages/sdcc.scm
+++ b/gnu/packages/sdcc.scm
@@ -20,6 +20,7 @@
(define-module (gnu packages sdcc)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages c)
#:use-module (gnu packages flex)
#:use-module (gnu packages python)
#:use-module (gnu packages texinfo)
@@ -68,3 +69,5 @@ HC08-based (hc08, s08), Zilog Z80-based MCUs (z80, z180, gbz80, Rabbit
Work is in progress on supporting the Microchip PIC16 and PIC18 targets.
It can be retargeted for other microprocessors.")
(license license:gpl2+)))
+
+(define-public sdcc-wrapper (wrap-cc sdcc))