aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 22:59:23 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:18 -0500
commit7799d17f8ba75cf4811e1f523f1b06518e2b6b70 (patch)
tree33df2328ca69c0a09ddaff9718b3384c31458802
parentf9d78c7f785db7a1e41e7dd49a36fc999c295ca2 (diff)
downloadpatches-7799d17f8ba75cf4811e1f523f1b06518e2b6b70.tar
patches-7799d17f8ba75cf4811e1f523f1b06518e2b6b70.tar.gz
gnu: Add ghc-splitmix.
* gnu/packages/haskell-xyz.scm (ghc-splitmix): New variable. (ghc-splitmix-bootstrap): Inherit from 'ghc-splitmix'.
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f2363a655f..7edca40a77 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9475,9 +9475,9 @@ splitting lists into parts, akin to the @code{split} function found in several
mainstream languages.")
(license license:bsd-3)))
-(define-public ghc-splitmix-bootstrap
+(define-public ghc-splitmix
(package
- (name "ghc-splitmix-bootstrap")
+ (name "ghc-splitmix")
(version "0.0.3")
(source
(origin
@@ -9487,11 +9487,15 @@ mainstream languages.")
(sha256
(base32
"1k0amgkz7rvyz3lnw7m786ilnr1cibwhx9sc4qynq329gxan5r7w"))))
- (properties '((hidden? #t)))
(build-system haskell-build-system)
- (arguments `(#:tests? #f))
(inputs
`(("ghc-random" ,ghc-random)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-async" ,ghc-async)
+ ("ghc-base-compat-batteries" ,ghc-base-compat-batteries)
+ ("ghc-tf-random" ,ghc-tf-random)
+ ("ghc-vector" ,ghc-vector)))
(home-page "http://hackage.haskell.org/package/splitmix")
(synopsis "Fast and splittable pseudorandom number generator")
(description "This package provides a Pure Haskell implementation of the
@@ -9508,6 +9512,14 @@ are easily inverted, and two successive outputs suffice to reconstruct the
internal state).")
(license license:bsd-3)))
+(define-public ghc-splitmix-bootstrap
+ (package
+ (inherit ghc-splitmix)
+ (name "ghc-splitmix-bootstrap")
+ (arguments `(#:tests? #f))
+ (native-inputs '())
+ (properties '((hidden? #t)))))
+
(define-public ghc-statevar
(package
(name "ghc-statevar")