summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-22 00:25:26 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-22 01:30:10 +0200
commitef1d475b00822194e8e4db794756815d00b7d132 (patch)
tree8e712463bf0740a500ecd254d3c25dabc97c739c
parentc7d2dd69004b020de5d86898d2497ab3c8435c37 (diff)
downloadpatches-ef1d475b00822194e8e4db794756815d00b7d132.tar
patches-ef1d475b00822194e8e4db794756815d00b7d132.tar.gz
gnu: llvm: Remove unused 'package-elisp-from-package' procedure.
This private procedure had been unused since 3a3d4d9d545028cda846ae827a60249f7162d34e. * gnu/packages/llvm.scm (package-elisp-from-package): Remove.
-rw-r--r--gnu/packages/llvm.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 15e15281a7..47b490aac8 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -866,35 +866,6 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
"This package provides a Python binding to LLVM for use in Numba.")
(license license:bsd-3)))
-(define (package-elisp-from-package source-package package-name
- source-files)
- "Return a package definition named PACKAGE-NAME that packages the Emacs Lisp
-SOURCE-FILES found in SOURCE-PACKAGE."
- (let ((orig (package-source source-package)))
- (package
- (inherit source-package)
- (name package-name)
- (build-system emacs-build-system)
- (source (origin
- (method (origin-method orig))
- (uri (origin-uri orig))
- (sha256 (origin-sha256 orig))
- (file-name (string-append package-name "-"
- (package-version source-package)))
- (modules '((guix build utils)
- (srfi srfi-1)
- (ice-9 ftw)))
- (snippet
- `(let* ((source-files (quote ,source-files))
- (basenames (map basename source-files)))
- (map copy-file
- source-files basenames)
- (map delete-file-recursively
- (fold delete
- (scandir ".")
- (append '("." "..") basenames)))
- #t)))))))
-
(define-public emacs-clang-format
(package
(inherit clang)