summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-05-19 11:48:07 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-05-21 13:23:37 +0100
commite5082a1e6a3cf54fc1439d350c84210c18ae9557 (patch)
tree87f64ff5c573296dfd00547c771f51fd2b18e2e0
parentab82124f0ea186b1fb054c69085c7c5b7e1dc2ae (diff)
downloadpatches-e5082a1e6a3cf54fc1439d350c84210c18ae9557.tar
patches-e5082a1e6a3cf54fc1439d350c84210c18ae9557.tar.gz
gnu: Add perl-datetime-format-iso8601.
* gnu/packages/perl.scm (perl-datetime-format-iso8601): New variable.
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d32e7b6ece..220519cde1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3079,6 +3079,34 @@ formats, as defined in RFC 2445. It can be used to parse these formats in
order to create the appropriate objects.")
(license (package-license perl))))
+(define-public perl-datetime-format-iso8601
+ (package
+ (name "perl-datetime-format-iso8601")
+ (version "0.08")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JH/JHOBLITT/DateTime-Format-ISO8601-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1syccqd5jlwms8v78ksnf68xijzl97jky5vbwhnyhxi5gvgfx8xk"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-datetime" ,perl-datetime)
+ ("perl-datetime-format-builder" ,perl-datetime-format-builder)
+ ("perl-file-find-rule" ,perl-file-find-rule)
+ ("perl-test-distribution" ,perl-test-distribution)
+ ("perl-test-pod" ,perl-test-pod)))
+ (home-page "https://metacpan.org/release/DateTime-Format-ISO8601")
+ (synopsis "Parse ISO8601 date and time formats")
+ (description "@code{DateTime::Format::ISO8601} is a DateTime
+extension that parses almost all ISO8601 date and time formats.")
+ (license perl-license)))
+
(define-public perl-datetime-format-natural
(package
(name "perl-datetime-format-natural")