summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-05-21 12:56:37 -0400
committerLeo Famulari <leo@famulari.name>2020-05-22 18:53:46 -0400
commitcfe4b6e29d33104cb60a1d15e24b2b74733f0501 (patch)
tree3bd53fd91483e3d93742297df4d2024afa59797d
parent7df8cb254e2683b9f6e8cc5302b8babbd44b1eb4 (diff)
downloadpatches-cfe4b6e29d33104cb60a1d15e24b2b74733f0501.tar
patches-cfe4b6e29d33104cb60a1d15e24b2b74733f0501.tar.gz
gnu: go-github-com-lucas-clemente-quic-go: Update to 0.14.4.
* gnu/packages/golang.scm (go-github-com-lucas-clemente-quic-go): Update to 0.14.4. [propagated-inputs]: Add go-github-com-marten-seemann-chacha20.
-rw-r--r--gnu/packages/golang.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ac952b52da..c6f47aa144 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3114,7 +3114,7 @@ implementation of generics.")
(define-public go-github-com-lucas-clemente-quic-go
(package
(name "go-github-com-lucas-clemente-quic-go")
- (version "0.12.1")
+ (version "0.14.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3123,7 +3123,7 @@ implementation of generics.")
(file-name (git-file-name name version))
(sha256
(base32
- "156nhq4dvw7mr08j952248v81q7702phbn4mp228319sahnbv65h"))))
+ "04l3gqbc3gh079n8vgnrsf8ypgv8sl63xjf28jqfrb45v2l73vyz"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/lucas-clemente/quic-go"
@@ -3132,6 +3132,7 @@ implementation of generics.")
(propagated-inputs
`(("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
("go-github-com-cheekybits-genny" ,go-github-com-cheekybits-genny)
+ ("go-github-com-marten-seemann-chacha20" ,go-github-com-marten-seemann-chacha20)
("go-github-com-marten-seemann-qtls" ,go-github-com-marten-seemann-qtls)
("go-github-com-golang-protobuf-proto" ,go-github-com-golang-protobuf-proto)))
(synopsis "QUIC in Go")