summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-05-11 16:30:55 +0200
committerBrice Waegeneire <brice@waegenei.re>2020-05-22 22:57:54 +0200
commitc25ca6b79ea73a71eacbfa28a21ebdc5433e3c2a (patch)
tree765c5456c2114e097915fcb3c9070007fe4a9718
parent8b554a4e5a8a4b376db56d1e037eb804f2c12340 (diff)
downloadpatches-c25ca6b79ea73a71eacbfa28a21ebdc5433e3c2a.tar
patches-c25ca6b79ea73a71eacbfa28a21ebdc5433e3c2a.tar.gz
gnu: libnma: Update inputs.
* gnu/packages/gnome.scm (libnam)[arguments]: Remove 'glib-or-gtk?' and add phase 'patch-docbook-xml'. [native-inputs]: Add 'docboock-xml-4.3' and 'vala'. [inputs]: Remove 'adwaita'icon-theme'. squash! gnu: libnma: Update inputs and licenses.
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 19 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f9756e4308..3394c1eb75 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -820,16 +820,26 @@ client devices can handle.")
"09mp6k0hfam1vyyv9kcd8j4gb2r58i05ipx2nswb58ris599bxja"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook")))
+ (substitute* "libnma-docs.xml"
+ (("http://.*/docbookx\\.dtd")
+ (string-append xmldoc "/docbookx.dtd")))
+ #t))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
+ `(("docbook-xml" ,docbook-xml-4.3)
+ ("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gtk-doc" ,gtk-doc)
("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
(inputs
- `(("adwaita-icon-theme" ,adwaita-icon-theme)
- ("gcr" ,gcr)
+ `(("gcr" ,gcr)
("gtk+" ,gtk+)
("iso-codes" ,iso-codes)
("mobile-broadband-provider-info" ,mobile-broadband-provider-info)
@@ -838,11 +848,10 @@ client devices can handle.")
(description "Libnma is an applet library for Network Manager. It was
initially part of network-manager-applet and has now become a separate
project.")
- (home-page "https://gitlab.gnome.org/GNOME/libnma")
-
- ;; Some files carry the "GPL-2.0+" SPDX identifier while others say
- ;; "LGPL-2.1+".
- (license license:gpl2+)))
+ (home-page "https://gitlab.gnome.org/GNOME/libnma")
+ ;; Some files carry the "GPL-2.0+" SPDX identifier while others say
+ ;; "LGPL-2.1+".
+ (license license:gpl2+)))
(define-public gnome-menus
(package