summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-20 18:42:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-20 23:51:26 +0200
commitc09bc60ded3a50e30f4c1361f6d0a4551dce02e3 (patch)
tree3ca4434bae69a07bc08613f60375e11482641994
parent305e9b33ca25f6d6c017fa988d72e08760dc0074 (diff)
downloadpatches-c09bc60ded3a50e30f4c1361f6d0a4551dce02e3.tar
patches-c09bc60ded3a50e30f4c1361f6d0a4551dce02e3.tar.gz
gnu: Add ruby-spinach.
* gnu/packages/ruby.scm (ruby-spinach): New public variable.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 248518b957..3201f9f38a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4253,6 +4253,34 @@ file or directories are modified.")
(home-page "https://guardgem.org/")
(license license:expat)))
+(define-public ruby-spinach
+ (package
+ (name "ruby-spinach")
+ (version "0.11.0")
+ (home-page "http://github.com/codegram/spinach")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "spinach" version))
+ (sha256
+ (base32
+ "1mv053mqz9c8ngqa6wp1ymk2fax6j0yqzax6918akrdr7c3fx3c6"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; FIXME: Disable tests altogether because they depend on 'capybara'
+ ;; which in turn depends on many other unpackaged gems. Enable once
+ ;; capybara is available.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-colorize" ,ruby-colorize)
+ ("ruby-gherkin-ruby" ,ruby-gherkin-ruby)
+ ("ruby-json" ,ruby-json)))
+ (synopsis "Gherkin-based BDD framework")
+ (description
+ "Spinach is a high-level @acronym{BDD, Behavior-driven development}
+framework that leverages the expressive @code{Gherkin} language to help you
+define executable specifications of your code.")
+ (license license:expat)))
+
(define-public ruby-tilt
(package
(name "ruby-tilt")