summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-21 21:03:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-21 21:55:23 +0200
commitb4f04e0efff1fb6112b84dc6d36ea46215c336b2 (patch)
tree7e63feb69f8ae3b3a0c7d4a47ccb6d922e73d0b4
parent29f4bb2e91ffe0da8f87832c909a33d51042a3bd (diff)
downloadpatches-b4f04e0efff1fb6112b84dc6d36ea46215c336b2.tar
patches-b4f04e0efff1fb6112b84dc6d36ea46215c336b2.tar.gz
gnu: cogl: Enable tests.
* gnu/packages/gnome.scm (cogl)[native-inputs]: Add XORG-SERVER-FOR-TESTS. [arguments]: Remove #:tests?. Add #:disallowed-references. Add #:phases to prepare test environment.
-rw-r--r--gnu/packages/gnome.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c523df50c3..938efbcdf3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4455,7 +4455,7 @@ throughout GNOME for API documentation).")
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
("gobject-introspection" ,gobject-introspection)
- ;;("xorg-server" ,xorg-server) ; for the test suite
+ ("xorg-server" ,xorg-server-for-tests)
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("glib" ,glib)
@@ -4474,7 +4474,8 @@ throughout GNOME for API documentation).")
("gst-plugins-base" ,gst-plugins-base)
("wayland" ,wayland)))
(arguments
- `(#:configure-flags (list "--enable-cogl-gst"
+ `(#:disallowed-references (,xorg-server-for-tests)
+ #:configure-flags (list "--enable-cogl-gst"
"--enable-wayland-egl-platform"
"--enable-wayland-egl-server"
@@ -4483,19 +4484,18 @@ throughout GNOME for API documentation).")
(string-append "--with-gl-libname="
(assoc-ref %build-inputs "mesa")
"/lib/libGL.so"))
- ;; XXX FIXME: All tests fail, with many warnings printed like this:
- ;; _FontTransOpen: Unable to Parse address
- ;; ${prefix}/share/fonts/X11/misc/
- #:tests? #f
- #; #:phases
- #;
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'start-xorg-server
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The test suite requires a running X server.
- (system (format #f "~a/bin/Xvfb :1 &"
- (assoc-ref inputs "xorg-server")))
- (setenv "DISPLAY" ":1")
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (begin
+ ;; The test suite requires a running X server.
+ (system (format #f "~a/bin/Xvfb :1 +extension GLX &"
+ (assoc-ref inputs "xorg-server")))
+ (setenv "DISPLAY" ":1")
+ #t)
+ (format #t "test suite not run~%"))
#t)))))
(home-page "https://www.cogl3d.org")
(synopsis "Object oriented GL/GLES Abstraction/Utility Layer")