summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-24 00:01:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-24 00:01:15 +0200
commitb1affd477882b8df39a2cdcc3c419be9322bf778 (patch)
tree92e870930ad6b0ee5e96ab13d73f829ffe90d0a9
parent21d3b765d9f22cdc2d027531411af27216592ef4 (diff)
downloadpatches-b1affd477882b8df39a2cdcc3c419be9322bf778.tar
patches-b1affd477882b8df39a2cdcc3c419be9322bf778.tar.gz
gnu: redshift-wayland: Install redshift.desktop.
* gnu/packages/xdisorg.scm (redshift-wayland)[arguments]: New field.
-rw-r--r--gnu/packages/xdisorg.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 1714cb8caf..acc74e328a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1238,6 +1238,24 @@ color temperature should be set to match the lamps in your room.")
(base32
"0nbkcw3avmzjg1jr1g9yfpm80kzisy55idl09b6wvzv2sz27n957"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'install 'create-desktop-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; For the GeoClue provider to work, a .desktop file
+ ;; needs to be provided. A template is available,
+ ;; but it only gets installed when the GUI is enabled.
+ ;; Install it manually for this Wayland variant.
+ (let* ((out (assoc-ref outputs "out"))
+ (desktop-file
+ (string-append
+ out "/share/applications/redshift.desktop")))
+ (mkdir-p (dirname desktop-file))
+ (copy-file "data/applications/redshift.desktop.in"
+ desktop-file)
+ (substitute* desktop-file
+ (("^_") ""))
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)