summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-05-21 14:20:39 -0400
committerLeo Famulari <leo@famulari.name>2020-05-22 18:53:46 -0400
commit7df8cb254e2683b9f6e8cc5302b8babbd44b1eb4 (patch)
treebdcf1bdd301e0ebd09b5d4a16ac38b8853d400e8
parent4a1bc86678df784b0c578e621275db10ffad0be4 (diff)
downloadpatches-7df8cb254e2683b9f6e8cc5302b8babbd44b1eb4.tar
patches-7df8cb254e2683b9f6e8cc5302b8babbd44b1eb4.tar.gz
gnu: Add go-github-com-marten-seemann-chacha20.
* gnu/packages/golang.scm (go-github-com-marten-seemann-chacha20): New variable.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 58016dcbf8..ac952b52da 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3065,6 +3065,28 @@ the Go standard library's TLS 1.3 implementation.")
(home-page "https://github.com/marten-seemann/qtls")
(license license:bsd-3)))
+(define-public go-github-com-marten-seemann-chacha20
+ (package
+ (name "go-github-com-marten-seemann-chacha20")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marten-seemann/chacha20")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x1j4cvbap45zk962qkjalc1h3axhzzdy9cdzhcjmprmm1ql4gjm"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/marten-seemann/chacha20"))
+ (synopsis "ChaCha20 in Go")
+ (description "This package is an external copy of the Go standard library's
+internal ChaCha20 package.")
+ (home-page "https://github.com/marten-seemann/chacha20")
+ (license license:bsd-3)))
+
(define-public go-github-com-cheekybits-genny
(package
(name "go-github-com-cheekybits-genny")