summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-05-21 12:55:10 -0400
committerLeo Famulari <leo@famulari.name>2020-05-22 18:53:46 -0400
commit64905c24ad56d9278d8790365647d10b2d8eddc4 (patch)
treeb9c547835a97810a0f4efedb68317f464c96f964
parent3a8935099f38005b53fe47b483d863a35ce1258e (diff)
downloadpatches-64905c24ad56d9278d8790365647d10b2d8eddc4.tar
patches-64905c24ad56d9278d8790365647d10b2d8eddc4.tar.gz
gnu: Add go-github-com-twmb-murmur3.
* gnu/packages/golang.scm (go-github-com-calmh-murmur3): Replace with ... (go-github-com-twmb-murmur3): ... new variable. (go-github-com-willf-bloom): Use go-github-com-twmb-murmur3.
-rw-r--r--gnu/packages/golang.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b5b868cb2d..3a9b109663 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2186,33 +2186,31 @@ Reference algorithm has been slightly hacked as to support the streaming mode
required by Go's standard Hash interface.")
(license license:bsd-3)))
-(define-public go-github-com-calmh-murmur3
- (let ((commit "74e9af8f47ac56901c490d45546ca167b60c7066")
- (revision "0"))
- (package
- (name "go-github-com-calmh-murmur3")
- (version (git-version "1.1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/calmh/murmur3.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0k8345ivx228qdbkl8bisd2wxwsinkb44ghba6r09538fr3fbr5w"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/calmh/murmur3"))
- (home-page "https://github.com/calmh/murmur3")
- (synopsis "Native MurmurHash3 Go implementation")
- (description "Native Go implementation of Austin Appleby's third
+(define-public go-github-com-twmb-murmur3
+ (package
+ (name "go-github-com-twmb-murmur3")
+ (version "1.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twmb/murmur3.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00riapwkyf23l5wyis47mbr8rwr4yrjw491jfc30wpzs111c1gyy"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/twmb/murmur3"))
+ (home-page "https://github.com/twmb/murmur3")
+ (synopsis "Native MurmurHash3 Go implementation")
+ (description "Native Go implementation of Austin Appleby's third
MurmurHash revision (aka MurmurHash3).
Reference algorithm has been slightly hacked as to support the streaming mode
required by Go's standard Hash interface.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public go-github-com-multiformats-go-multihash
(let ((commit "97cdb562a04c6ef66d8ed40cd62f8fbcddd396d6")
@@ -3496,14 +3494,14 @@ efficient space usage.")
(modify-phases %standard-phases
(add-after 'unpack 'patch-import-path
(lambda _
- ;; See 'go.mod' in the source distribution of Syncthing 1.4.1 for
+ ;; See 'go.mod' in the source distribution of Syncthing 1.5.0 for
;; more information.
;; <https://github.com/spaolacci/murmur3/issues/29>
(substitute* "src/github.com/willf/bloom/bloom.go"
- (("spaolacci") "calmh"))
+ (("spaolacci") "twmb"))
#t)))))
(propagated-inputs
- `(("go-github-com-calmh-murmur3" ,go-github-com-calmh-murmur3)
+ `(("go-github-com-twmb-murmur3" ,go-github-com-twmb-murmur3)
("go-github-com-willf-bitset" ,go-github-com-willf-bitset)))
(synopsis "Bloom filters in Go")
(description "This package provides a Go implementation of bloom filters,