summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-20 18:41:04 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-20 23:51:26 +0200
commit305e9b33ca25f6d6c017fa988d72e08760dc0074 (patch)
tree2385d44babb29e0f16a302d305798bd7737ead00
parent8f85018daaa3548e721c369511a654f5f7753653 (diff)
downloadpatches-305e9b33ca25f6d6c017fa988d72e08760dc0074.tar
patches-305e9b33ca25f6d6c017fa988d72e08760dc0074.tar.gz
gnu: Add ruby-colorize.
* gnu/packages/ruby.scm (ruby-colorize): New public variable.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4eb9d0d696..248518b957 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7842,6 +7842,36 @@ is part of Ruby's standard library. It more closely conforms to RFC 3986,
RFC 3987, and RFC 6570 (level 4), providing support for IRIs and URI templates.")
(license license:asl2.0)))
+(define-public ruby-colorize
+ (package
+ (name "ruby-colorize")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "colorize" version))
+ (sha256
+ (base32
+ "133rqj85n400qk6g3dhf2bmfws34mak1wqihvh3bgy9jhajw580b"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'remove-codeclimate-dependency
+ (lambda _
+ (substitute* "test/test_colorize.rb"
+ ;; Do not hook the tests into the online CodeClimate
+ ;; service which is unnecessary for these tests.
+ (("require 'codeclimate-test-reporter'")
+ "")
+ (("CodeClimate.*") ""))
+ #t)))))
+ (synopsis "Add color effects to the @code{String} class")
+ (description
+ "This package extends the @code{String} class and adds a
+@code{ColorizedString} with methods to set text color, background color,
+and text effects.")
+ (home-page "http://github.com/fazibear/colorize")
+ (license license:gpl2+)))
+
(define-public ruby-colorator
(package
(name "ruby-colorator")