summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-25 13:27:37 +0200
committerGuix Patches Tester <>2020-05-25 12:33:08 +0100
commit7e0c5f2b05405de7db9ec7d1137252a8955685e0 (patch)
tree2de1025a7ec8f231e1a31020d108c5050ff8b0c0
parent0246406df90faadf78ba37691c474a3bfd8752ed (diff)
downloadpatches-7e0c5f2b05405de7db9ec7d1137252a8955685e0.tar
patches-7e0c5f2b05405de7db9ec7d1137252a8955685e0.tar.gz
gnu: Add python-pytest-pycodestyle
* gnu/packages/python-check.scm (python-pytest-pycodestyle): New variable
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 22b9ea8df5..50911673b2 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -337,6 +337,31 @@ testing framework.")
framework.")
(license license:expat)))
+(define-public python-pytest-pycodestyle
+ (package
+ (name "python-pytest-pycodestyle")
+ (version "2.0.0") ;; Any version higher than that requires python-pytest~=5.4
+ ;; (python-pytest is at version 5.3.5 as I write this comment
+ ;; and 5478 packages depend on it.)
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-pycodestyle" version))
+ (sha256
+ (base32
+ "02i5gl7pm9cwxk15sn29inz3n8flpj1r3p1l110h43f2na5w8h7z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pycodestyle" ,python-pycodestyle)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page
+ "https://github.com/henry0312/pytest-pycodestyle")
+ (synopsis "Pytest plugin to run pycodestyle")
+ (description "This package provides a plugin to run pycodestyle for the py.test
+framework.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")