summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-19 11:58:02 +0200
committerGuix Patches Tester <>2020-05-25 12:33:07 +0100
commit0246406df90faadf78ba37691c474a3bfd8752ed (patch)
tree2fdc8b47b319fa0a968c3672f48c6f82de445acc
parent0b96705889df3d2fb9a14ec73213d137a256986c (diff)
downloadpatches-0246406df90faadf78ba37691c474a3bfd8752ed.tar
patches-0246406df90faadf78ba37691c474a3bfd8752ed.tar.gz
gnu: python-prompt-toolkit: Update to 3.0.5
* /gnu/packages/python-xyz.scm (python-widgetsnbextension): Pin python-prompt-toolkit to version 2 * /gnu/packages/python-xyz.scm (python-ipywidgets): Pin python-prompt-toolkit to version 2 * /gnu/packages/python-xyz.scm (python-jupyter-console): Pin python-prompt-toolkit to version 2 * /gnu/packages/python-xyz.scm (python-prompt-toolkit): Update to 3.0.5 * /gnu/packages/python-xyz.scm (python-prompt-toolkit-2): New variable * /gnu/packages/python-xyz.scm (python-prompt-toolkit-2-instead-of-prompt-toolkit): New variable * /gnu/packages/machine-learning.scm (python-iml): Pin ipython to python-prompt-toolkit-2 variant
-rw-r--r--gnu/packages/machine-learning.scm9
-rw-r--r--gnu/packages/python-xyz.scm48
2 files changed, 52 insertions, 5 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index cf00a84e86..e26768267b 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
+;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1816,12 +1817,14 @@ advanced research.")
"1k8szlpm19rcwcxdny9qdm3gmaqq8akb4xlvrzyz8c2d679aak6l"))))
(build-system python-build-system)
(propagated-inputs
- `(("ipython" ,python-ipython)
- ("nose" ,python-nose)
+ `(("ipython" ,(prompt-toolkit-2-instead-of-prompt-toolkit
+ python-ipython))
("numpy" ,python-numpy)
("pandas" ,python-pandas)
("scipy" ,python-scipy)))
- (home-page "http://github.com/interpretable-ml/iml")
+ (native-inputs
+ `(("nose" ,python-nose)))
+ (home-page "https://github.com/interpretable-ml/iml")
(synopsis "Interpretable Machine Learning (iML) package")
(description "Interpretable ML (iML) is a set of data type objects,
visualizations, and interfaces that can be used by any method designed to
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9aa5635ab8..9d48c42275 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8981,6 +8981,7 @@ interactive computing.")
(build-system python-build-system)
(propagated-inputs
`(("python-ipykernel" ,python-ipykernel)
+ ("python-prompt-toolkit" ,python-prompt-toolkit-2)
("python-notebook" ,python-notebook)))
(native-inputs
`(("python-certifi" ,python-certifi)
@@ -9009,6 +9010,7 @@ notebooks.")
(propagated-inputs
`(("python-ipython" ,python-ipython)
("python-traitlets" ,python-traitlets)
+ ("python-prompt-toolkit" ,python-prompt-toolkit-2)
("python-widgetsnbextension" ,python-widgetsnbextension)))
(native-inputs
`(("python-nose" ,python-nose)
@@ -9039,7 +9041,7 @@ in the data.")
(propagated-inputs
`(("python-ipykernel" ,python-ipykernel)
("python-jupyter-client" ,python-jupyter-client)
- ("python-prompt-toolkit" ,python-prompt-toolkit)
+ ("python-prompt-toolkit" ,python-prompt-toolkit-2)
("python-pygments" ,python-pygments)))
(native-inputs
`(("python-nose" ,python-nose)))
@@ -12105,6 +12107,44 @@ collections of data.")
(define-public python-prompt-toolkit
(package
(name "python-prompt-toolkit")
+ (version "3.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "prompt_toolkit" version))
+ (sha256
+ (base32
+ "1j3x5s4gp4ih73sbcni0a0vffbzvrxbrbnkvb3fzjgxn810ilgan"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'post-install-check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; HOME is needed for the test
+ ;; "test_pathcompleter_can_expanduser".
+ (setenv "HOME" "/tmp")
+ (add-installed-pythonpath inputs outputs)
+ (invoke "py.test"))))))
+ (propagated-inputs
+ `(("python-wcwidth" ,python-wcwidth)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page
+ "https://github.com/prompt-toolkit/python-prompt-toolkit")
+ (synopsis "Library for building command line interfaces in Python")
+ (description
+ "Prompt-Toolkit is a library for building interactive command line
+interfaces in Python. It's like GNU Readline but it also features syntax
+highlighting while typing, out-of-the-box multi-line input editing, advanced
+code completion, incremental search, support for Chinese double-width
+characters, mouse support, and auto suggestions.")
+ (license license:bsd-3)))
+
+(define-public python-prompt-toolkit-2
+ (package
+ (name "python-prompt-toolkit")
(version "2.0.7")
(source
(origin
@@ -12131,7 +12171,7 @@ collections of data.")
("python-pygments" ,python-pygments)))
(native-inputs
`(("python-pytest" ,python-pytest)))
- (home-page "https://github.com/jonathanslenders/python-prompt-toolkit")
+ (home-page "https://github.com/prompt-toolkit/python-prompt-toolkit")
(synopsis "Library for building command line interfaces in Python")
(description
"Prompt-Toolkit is a library for building interactive command line
@@ -12158,6 +12198,10 @@ characters, mouse support, and auto suggestions.")
(define-public python2-prompt-toolkit-1
(package-with-python2 python-prompt-toolkit-1))
+(define-public prompt-toolkit-2-instead-of-prompt-toolkit
+ (package-input-rewriting/spec
+ `(("python-prompt-toolkit" . ,(const python-prompt-toolkit-2)))))
+
(define-public python-jedi
(package
(name "python-jedi")