summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 15:32:50 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitf4e5c04ed15456a47c0e79fc80a6e5044de8a662 (patch)
tree344402390b860a39c4d6b71994e22ad59fdc2c0b
parent32ce3df7584c8a0536ba09797ae8c087c7998719 (diff)
downloadpatches-f4e5c04ed15456a47c0e79fc80a6e5044de8a662.tar
patches-f4e5c04ed15456a47c0e79fc80a6e5044de8a662.tar.gz
gnu: Add ghc-clock.
Add ghc-clock, which depends indirectly on ghc-clock-bootstrap for its test suite. * gnu/packages/haskell.scm (ghc-clock): New variable.
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index be9c76d60b..825cda1b6a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2435,6 +2435,29 @@ unbounded @code{Integer} type.")
timer functions of different operating systems via a unified API.")
(license bsd-3)))
+(define-public ghc-clock
+ (package
+ (name "ghc-clock")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/"
+ "clock/"
+ "clock-" version ".tar.gz"))
+ (sha256
+ (base32 "1ncph7vi2q6ywwc8ysxl1ibw6i5dwfvln88ssfazk8jgpj4iyykw"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "https://hackage.haskell.org/package/clock")
+ (synopsis "High-resolution clock for Haskell")
+ (description "A package for convenient access to high-resolution clock and
+timer functions of different operating systems via a unified API.")
+ (license bsd-3)))
+
(define-public ghc-charset
(package
(name "ghc-charset")