summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:11:03 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commita24ec6f271675acb760d197a1a6eb8ba395cb5d0 (patch)
treeb147fb88e05d9467acf65922d6f8862bedf26f5b
parent7f0d5857e64f33f3843248ddac68a441a47a4e06 (diff)
downloadpatches-a24ec6f271675acb760d197a1a6eb8ba395cb5d0.tar
patches-a24ec6f271675acb760d197a1a6eb8ba395cb5d0.tar.gz
gnu: Add ghc-unbounded-delays.
* gnu/packages/haskell.scm (ghc-unbounded-delays): New variable.
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1d5fa6c6a5..63b1603a47 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2216,6 +2216,29 @@ periodic, on-demand actions in Haskell.")
having to unsafely pass dummy arguments.")
(license bsd-3)))
+(define-public ghc-unbounded-delays
+ (package
+ (name "ghc-unbounded-delays")
+ (version "0.1.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/unbounded-delays/unbounded-delays-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1f4h87503m3smhip432q027wj3zih18pmz2rnafh60589ifcl420"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/basvandijk/unbounded-delays")
+ (synopsis "Unbounded thread delays and timeouts")
+ (description "The @code{threadDelay} and @code{timeout} functions from the
+Haskell base library use the bounded @code{Int} type for specifying the delay
+or timeout period. This package provides alternative functions which use the
+unbounded @code{Integer} type.")
+ (license bsd-3)))
+
(define-public ghc-doctest
(package
(name "ghc-doctest")