summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 13:56:59 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit71470eddfa585b45b1de0d3c7e2ba058ea88c5a6 (patch)
tree15c885da9c8e6197a2c6260109d77ada794cc49f
parent9525e25fc1daa6c551ef6a979e8edd36c557931a (diff)
downloadpatches-71470eddfa585b45b1de0d3c7e2ba058ea88c5a6.tar
patches-71470eddfa585b45b1de0d3c7e2ba058ea88c5a6.tar.gz
gnu: Add ghc-base-compat.
* gnu/packages/haskell.scm (ghc-base-compat): New variable.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d3fc7693dc..9dea805abe 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1952,6 +1952,31 @@ a subset of @code{MonadBase} into which generic control operations such as
system.")
(license bsd-3)))
+(define-public ghc-base-compat
+ (package
+ (name "ghc-base-compat")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/base-compat/base-compat-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "02m93hzgxg4bcnp7xcc2fdh2hrsc2h6fwl8hix5nx9k864kwf41q"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://hackage.haskell.org/package/base-compat")
+ (synopsis "Haskell compiler compatibility library")
+ (description "This library provides functions available in later versions
+of base to a wider range of compilers, without requiring the use of CPP
+pragmas in your code.")
+ (license bsd-3)))
+
(define-public ghc-easy-file
(package
(name "ghc-easy-file")