summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:18:48 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit27e7c8b6a6c3a49ac8f734232c9e7f4407937a46 (patch)
treed6a5c9ef7544c5c85e39357f61f690979ef92916
parent85160205074a3213cfd3168b786a2af5555f13a8 (diff)
downloadpatches-27e7c8b6a6c3a49ac8f734232c9e7f4407937a46.tar
patches-27e7c8b6a6c3a49ac8f734232c9e7f4407937a46.tar.gz
gnu: Add ghc-byteorder.
* gnu/packages/haskell.scm (ghc-byteorder): New variable.
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 717eef0a12..7c07ff2dea 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1928,6 +1928,30 @@ a subset of @code{MonadBase} into which generic control operations such as
@code{catch} can be lifted from @code{IO} or any other base monad.")
(license bsd-3)))
+(define-public ghc-byteorder
+ (package
+ (name "ghc-byteorder")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/byteorder/byteorder-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "06995paxbxk8lldvarqpb3ygcjbg4v8dk4scib1rjzwlhssvn85x"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://community.haskell.org/~aslatter/code/byteorder")
+ (synopsis
+ "Exposes the native endianness of the system")
+ (description
+ "This package is for working with the native byte-ordering of the
+system.")
+ (license bsd-3)))
+
(define-public ghc-async
(package
(name "ghc-async")