summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-11 14:08:46 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-16 11:09:49 +0100
commitd6e21589afb29e4d6d5b124cbfd533299567fb28 (patch)
treefe5766dcf0f358007dff94a957d09c69859a56ae
parent81a4228b185b64415f98c5d812602ab0da240e5d (diff)
downloadpatches-d6e21589afb29e4d6d5b124cbfd533299567fb28.tar
patches-d6e21589afb29e4d6d5b124cbfd533299567fb28.tar.gz
gnu: Add r-devtools.
* gnu/packages/statistics.scm (r-devtools): New variable.
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 896f52993a..2af9de2344 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1235,3 +1235,32 @@ pure C implementation of the Git core methods.")
"This package provides functions to access the RStudio API and provide
informative error messages when it's not available.")
(license license:expat)))
+
+(define-public r-devtools
+ (package
+ (name "r-devtools")
+ (version "1.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "devtools" version))
+ (sha256
+ (base32
+ "10ycx3kkiz5x8nmgw31d9wa5hhlx2fhda2nqzxfrczqpz1jik6ci"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-digest" ,r-digest)
+ ("r-evaluate" ,r-evaluate)
+ ("r-git2r" ,r-git2r)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-memoise" ,r-memoise)
+ ("r-roxygen2" ,r-roxygen2)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-rversions" ,r-rversions)
+ ("r-whisker" ,r-whisker)))
+ (home-page "https://github.com/hadley/devtools")
+ (synopsis "Tools to make developing R packages easier")
+ (description "The devtools package is a collection of package development
+tools to simplify the devolpment of R packages.")
+ (license license:gpl2+)))