summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-01-20 22:37:01 +0100
committerAndreas Enge <andreas@enge.fr>2015-01-20 22:42:28 +0100
commit673ab897a34dfa92aae21c431d8963eb2fc4f0d9 (patch)
treebfdcf2d760ce501ca042d6530dbe9ce7c849af09
parent1a0965045bfa7eb277efb0cd8c3513b5c03ba810 (diff)
downloadpatches-673ab897a34dfa92aae21c431d8963eb2fc4f0d9.tar
patches-673ab897a34dfa92aae21c431d8963eb2fc4f0d9.tar.gz
gnu: Add python-html5lib.
* gnu/packages/python.scm (python-html5lib, python2-html5lib): New variables.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a0e682c8b6..4b88dc7845 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2840,3 +2840,34 @@ ISO 8601 dates, time and duration.")
(define-public python2-isodate
(package-with-python2 python-isodate))
+
+(define-public python-html5lib
+ (package
+ (name "python-html5lib")
+ (version "1.0b3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/h/html5lib/html5lib-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1l5i6xzckzx4hnh9qzv9q3kyhkgjx2hsi2k9srgci3qizjmvp6ln"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:test-target "check"))
+ (home-page
+ "https://github.com/html5lib/html5lib-python")
+ (synopsis
+ "Python HTML parser based on the WHATWG HTML specifcation")
+ (description
+ "Html5lib is an HTML parser based on the WHATWG HTML specifcation
+and written in Python.")
+ (license expat)))
+
+(define-public python2-html5lib
+ (package-with-python2 python-html5lib))