summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-08-24 12:43:52 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-08-26 11:48:22 +0530
commit2cad58ca6f1b1dfe23a1ca6f608df75935459b33 (patch)
treef4863311fa10a355be5ec222fe51008a9fd724ed
parent7550f4b0ef250268af7b5cc97ea9e1215371cec4 (diff)
downloadpatches-2cad58ca6f1b1dfe23a1ca6f608df75935459b33.tar
patches-2cad58ca6f1b1dfe23a1ca6f608df75935459b33.tar.gz
gnu: ghc-scientific: Update to 0.3.6.2.
* gnu/packages/haskell.scm (ghc-scientific): Update to 0.3.6.2. [inputs]: Move ghc-tasty ... [native-inputs]: ... to here.
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cb4c0efef6..7d7d85f951 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5086,7 +5086,7 @@ in migrated modules.")
(define-public ghc-scientific
(package
(name "ghc-scientific")
- (version "0.3.5.2")
+ (version "0.3.6.2")
(source
(origin
(method url-fetch)
@@ -5096,14 +5096,15 @@ in migrated modules.")
".tar.gz"))
(sha256
(base32
- "0msnjz7ml0zycw9bssslxbg0nigziw7vs5km4q3vjbs8jpzpkr2w"))))
+ "03ql2f0ac8bsl524idy9xxa3kxisb2sj3avflzw580j5hzy0m397"))))
(build-system haskell-build-system)
(inputs
`(("ghc-integer-logarithms" ,ghc-integer-logarithms)
("ghc-text" ,ghc-text)
("ghc-hashable" ,ghc-hashable)
- ("ghc-primitive" ,ghc-primitive)
- ("ghc-tasty" ,ghc-tasty)
+ ("ghc-primitive" ,ghc-primitive)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
("ghc-tasty-ant-xml" ,ghc-tasty-ant-xml)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-tasty-smallcheck" ,ghc-tasty-smallcheck)