summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-10 11:32:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-16 15:22:37 +0200
commit2776d72c7cdea26ac997c4dc8a5190c788c36b29 (patch)
treead222054a6f4124b5d0ec47cd66a6b1ceff9b8e4
parent782770d1c2fb00b77bf23d3d556bb980af0faac2 (diff)
downloadpatches-2776d72c7cdea26ac997c4dc8a5190c788c36b29.tar
patches-2776d72c7cdea26ac997c4dc8a5190c788c36b29.tar.gz
gnu: vte: Provide 0.36.5.
* gnu/packages/gnome.scm (vte): Add version 0.36.5.
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4bd9d9c881..8eec16df91 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1708,6 +1709,27 @@ gnome-terminal, but can also be used to embed a console/terminal in games,
editors, IDEs, etc.")
(license license:lgpl2.1+)))
+;; provides vte 2.90, required for some terminal emulators
+;; tilda bug: https://github.com/lanoxx/tilda/issues/94
+;; pantheon-terminal bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=788021
+;; roxterm bug: http://sourceforge.net/p/roxterm/bugs/107/
+;; pantheon-terminal, roxterm are not currently packaged
+(define-public vte-0.36
+ (package (inherit vte)
+ (name "vte")
+ (version "0.36.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1psfnqsmxx4qzc55qwvb8jai824ix4pqcdqhgxk0g2zh82bcxhn2"))))
+ (propagated-inputs
+ `(("gtk" ,gtk+)
+ ("ncurses" ,ncurses)))))
+
;; stable version for gtk2, required by xfce4-terminal.
(define-public vte/gtk+-2
(package (inherit vte)