summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-14 23:41:47 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commite2fcaff2ef3804cc9e4b29e9dc99e896439c2f45 (patch)
treec4938b38e1e61fbeab82f76c32adb40a6d40c92c
parent9380634c1037fa602a6d8896e94573bbf1f72396 (diff)
downloadpatches-e2fcaff2ef3804cc9e4b29e9dc99e896439c2f45.tar
patches-e2fcaff2ef3804cc9e4b29e9dc99e896439c2f45.tar.gz
gnu: Add ghc-async.
* gnu/packages/haskell.scm (ghc-async): New variable.
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a5ae4d14dc..9e9f18c058 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1228,4 +1228,30 @@ lets you set up HTTP connections, transmitting requests and processing the
responses coming back.")
(license bsd-3)))
+(define-public ghc-async
+ (package
+ (name "ghc-async")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/async/async-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0azx4qk65a9a2gvqsfmz3w89m6shzr2iz0i5lly2zvly4n2d6m6v"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+ (propagated-inputs
+ `(("ghc-stm" ,ghc-stm)))
+ (home-page "https://github.com/simonmar/async")
+ (synopsis "Library to run IO operations asynchronously")
+ (description "Async provides a library to run IO operations
+asynchronously, and wait for their results. It is a higher-level interface
+over threads in Haskell, in which @code{Async a} is a concurrent thread that
+will eventually deliver a value of type @code{a}.")
+ (license bsd-3)))
+
;;; haskell.scm ends here