summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:07:02 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitdf12a41294df0af81e2bcbf9ac6ede35a1cd5147 (patch)
treee3da869443617624d3ec4dac4b0f673989e596c0
parent6d71fcdf9ea6536593feadcb2b08a2e2b6b49a08 (diff)
downloadpatches-df12a41294df0af81e2bcbf9ac6ede35a1cd5147.tar
patches-df12a41294df0af81e2bcbf9ac6ede35a1cd5147.tar.gz
gnu: Add ghc-hspec.
* gnu/packages/haskell.scm (ghc-hspec): New variable.
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fa8e07822c..3c8c1fce75 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1394,6 +1394,36 @@ lets you set up HTTP connections, transmitting requests and processing the
responses coming back.")
(license bsd-3)))
+(define-public ghc-hspec
+ (package
+ (name "ghc-hspec")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/hspec/hspec-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0zqisxznlbszivsgy3irvf566zhcr6ipqqj3x9i7pj5hy913jwqf"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-hspec-core" ,ghc-hspec-core)
+ ("hspec-discover" ,hspec-discover)
+ ("ghc-hspec-expectations" ,ghc-hspec-expectations)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)))
+ (inputs
+ `(("ghc-stringbuilder" ,ghc-stringbuilder)
+ ("ghc-hspec-meta" ,ghc-hspec-meta)))
+ (home-page "http://hspec.github.io/")
+ (synopsis "Testing Framework for Haskell")
+ (description "This library provides the Hspec testing framework for
+Haskell, inspired by the Ruby library RSpec.")
+ (license expat)))
+
(define-public ghc-hspec-expectations
(package
(name "ghc-hspec-expectations")