summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:10:01 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitb10f7be3e36473614cf3d1bbd852d30eb3f63218 (patch)
treecc163ee1a99b127bfdcb386bd2aaf671e72999b6
parent476f7bab8b1782b9c6a52f2146c4c03b49fb0718 (diff)
downloadpatches-b10f7be3e36473614cf3d1bbd852d30eb3f63218.tar
patches-b10f7be3e36473614cf3d1bbd852d30eb3f63218.tar.gz
gnu: Add ghc-pcre-light.
* gnu/packages/haskell.scm (ghc-pcre-light): New variable.
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e75e46ba7e..1775e8eb28 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages python)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages xorg))
(define ghc-bootstrap-x86_64-7.8.4
@@ -1027,6 +1028,31 @@ exceptions.")
deriving mechanism in Haskell to arbitrary classes.")
(license bsd-3)))
+(define-public ghc-pcre-light
+ (package
+ (name "ghc-pcre-light")
+ (version "0.4.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/pcre-light/pcre-light-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0l1df2sk5qwf424bvb8mbdkr2xjg43fi92n5r22yd7vm1zz0jqvf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("pcre" ,pcre)))
+ (home-page "https://github.com/Daniel-Diaz/pcre-light")
+ (synopsis "Haskell library for Perl 5 compatible regular expressions")
+ (description "This package provides a small, efficient, and portable regex
+library for Perl 5 compatible regular expressions. The PCRE library is a set
+of functions that implement regular expression pattern matching using the same
+syntax and semantics as Perl 5.")
+ (license bsd-3)))
+
(define-public ghc-exceptions
(package
(name "ghc-exceptions")