summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:00:17 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commita311f5d00089287b1a6192f65397d93a932027c8 (patch)
tree99892bc0be3e205d3c0fdd586ceb217206ceadb7
parent94e1dc7a57a4a1e4ab2003f04408e87088b25125 (diff)
downloadpatches-a311f5d00089287b1a6192f65397d93a932027c8.tar
patches-a311f5d00089287b1a6192f65397d93a932027c8.tar.gz
gnu: Add ghc-blaze-markup.
* gnu/packages/haskell.scm (ghc-blaze-markup): New variable.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a2650ce159..4c52f02e72 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2005,6 +2005,31 @@ bridge to the new builder, so that code that uses the old interface can
interoperate with code that uses the new implementation.")
(license bsd-3)))
+(define-public ghc-blaze-markup
+ (package
+ (name "ghc-blaze-markup")
+ (version "0.7.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/blaze-markup/blaze-markup-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "080vlhd8dwjxrma4bb524lh8gxs5lm3xh122icy6lnnyipla0s9y"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+ (propagated-inputs
+ `(("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-text" ,ghc-text)))
+ (home-page "http://jaspervdj.be/blaze")
+ (synopsis "Fast markup combinator library for Haskell")
+ (description "This library provides core modules of a markup combinator
+library for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-easy-file
(package
(name "ghc-easy-file")