summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:16:45 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit899916b51ed6cfc4185a2ab97cd7af20c931d476 (patch)
tree0b627890e23f127e4c0533d292aa068366950f47
parent6ecc4723c2b9f97cade7ff7a76d6d4a1fb4f2e72 (diff)
downloadpatches-899916b51ed6cfc4185a2ab97cd7af20c931d476.tar
patches-899916b51ed6cfc4185a2ab97cd7af20c931d476.tar.gz
gnu: Add ghc-mmorph.
* gnu/packages/haskell.scm (ghc-mmorph): New variable.
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2eec529218..02ab82faca 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1850,6 +1850,29 @@ different keys; hence the name. Also provided is a @code{locker} type,
representing a store for a single element.")
(license bsd-3)))
+(define-public ghc-mmorph
+ (package
+ (name "ghc-mmorph")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/mmorph/mmorph-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0k5zlzmnixfwcjrqvhgi3i6xg532b0gsjvc39v5jigw69idndqr2"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://hackage.haskell.org/package/mmorph")
+ (synopsis "Monad morphisms")
+ (description
+ "This library provides monad morphism utilities, most commonly used for
+manipulating monad transformer stacks.")
+ (license bsd-3)))
+
(define-public ghc-async
(package
(name "ghc-async")