summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:13:33 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit5ef40cb26a70a48680ce32875d7f0c4f2a95c746 (patch)
tree17b7641cd2a176c528f4967380d045daf6f6b4ba
parent685502dc936dc7362026dca6a6267651db7c6049 (diff)
downloadpatches-5ef40cb26a70a48680ce32875d7f0c4f2a95c746.tar
patches-5ef40cb26a70a48680ce32875d7f0c4f2a95c746.tar.gz
gnu: Add ghc-unix-time.
* gnu/packages/haskell.scm (ghc-unix-time): New variable.
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d15a9ad4cd..ebaf1f75e0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -968,6 +968,38 @@ transformers 0.2 or 0.3 compatibility to run on old versions of the platform,
but also need those types.")
(license bsd-3)))
+(define-public ghc-unix-time
+ (package
+ (name "ghc-unix-time")
+ (version "0.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/unix-time/unix-time-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dyvyxwaffb94bgri1wc4b9wqaasy32pyjn0lww3dqblxv8fn5ax"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f ; FIXME: Test fails with "System.Time not found". This is
+ ; weird, that should be provided by GHC 7.10.2.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-/bin/sh
+ (lambda _
+ (setenv "CONFIG_SHELL" "sh"))))))
+ (propagated-inputs
+ `(("ghc-old-time" ,ghc-old-time)
+ ("ghc-old-locale" ,ghc-old-locale)))
+ (home-page "http://hackage.haskell.org/package/unix-time")
+ (synopsis "Unix time parser/formatter and utilities")
+ (description "This library provides fast parsing and formatting utilities
+for Unix time in Haskell.")
+ (license bsd-3)))
+
(define-public ghc-iproute
(package
(name "ghc-iproute")