summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:09:27 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit476f7bab8b1782b9c6a52f2146c4c03b49fb0718 (patch)
tree3ede8a6daa2cb76e4af26d108653b612fc5e243f
parent78c5b39d0877eca8fa0c18e239f1bcf966b7a01a (diff)
downloadpatches-476f7bab8b1782b9c6a52f2146c4c03b49fb0718.tar
patches-476f7bab8b1782b9c6a52f2146c4c03b49fb0718.tar.gz
gnu: Add ghc-generic-deriving.
* gnu/packages/haskell.scm (ghc-generic-deriving): New variable.
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c6dea86d64..e75e46ba7e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1006,6 +1006,27 @@ style.")
exceptions.")
(license bsd-3)))
+(define-public ghc-generic-deriving
+ (package
+ (name "ghc-generic-deriving")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/generic-deriving/generic-deriving-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1kc6lhdanls6kgpk8xv5xi14lz1sngcd8xn930hkf7ilq4kxkcr6"))))
+ (build-system haskell-build-system)
+ (home-page "https://hackage.haskell.org/package/generic-deriving")
+ (synopsis "Generalise the deriving mechanism to arbitrary classes")
+ (description "This package provides functionality for generalising the
+deriving mechanism in Haskell to arbitrary classes.")
+ (license bsd-3)))
+
(define-public ghc-exceptions
(package
(name "ghc-exceptions")