summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-23 09:43:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-23 09:45:14 +0200
commit28e9a1118b8dc3c14d1ffc0533ac2c6683f65ad0 (patch)
treee1a8d6b782a743ce3aabe133839f5295c390cb59
parentb2d81186165631c50a6e760b52d5830409b65585 (diff)
downloadpatches-28e9a1118b8dc3c14d1ffc0533ac2c6683f65ad0.tar
patches-28e9a1118b8dc3c14d1ffc0533ac2c6683f65ad0.tar.gz
gnu: emacs-flycheck-grammalecte: Remove "/usr/bin/env" references.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte)[arguments]: Fix more python3 locations.
-rw-r--r--gnu/packages/emacs-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8951119da9..fe68a56fd6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3797,13 +3797,15 @@ for Flow files.")
#:emacs ,emacs ;need libxml support
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-python-executable
- ;; Hardcode python3 executable in the Emacs library.
+ (add-after 'unpack 'specify-python-location
+ ;; Hard-code python3 executable location in the library.
(lambda* (#:key inputs #:allow-other-keys)
(let ((python3 (string-append (assoc-ref inputs "python")
"/bin/python3")))
(substitute* "flycheck-grammalecte.el"
(("\"python3") (string-append "\"" python3)))
+ (substitute* '("conjugueur.py" "flycheck-grammalecte.py")
+ (("/usr/bin/env python3?") python3))
#t)))
(add-before 'build 'link-to-grammalecte
;; XXX: The Python part of the package requires grammalecte, but